package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d){3}([^x]|x[^\d]).*`)
var str = `555x555asdawe234rwf
2x2xvxsdd
555aseeaweqwe
555xwae`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}