// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d){3}([^x]|x[^\d]).*").unwrap();
let string = "555x555asdawe234rwf
2x2xvxsdd
555aseeaweqwe
555xwae";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}