package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$(\d+(,?\d+)*)\+`)
var str = `$10,000,000+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}