$re = '/\$(\d+(,?\d+)*)\+/';
$str = '$10,000,000+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);