import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a[^>]*>([^<]+)<\\/a>+";
final String string = "<div class=\"row mb-xlg\"><div class=\"col-md-12\">\n"
+ "<div class=\"heading heading-border heading-middle-border\"><h3>Compatible Models</h3></div>\n"
+ "<div class=\"row show-grid\">\n"
+ "<div class=\"col-md-4\"><a href=\"/model/SFSPC19S80/_/_/Sanyo/PC19S80/\" title=\"Sanyo PC19S80 Remote Control (Pc-27s80)\">PC19S80</a></div>\n"
+ "<div class=\"col-md-4\"><a href=\"/model/SFSPC25580/_/_/Sanyo/PC25580/\" title=\"Sanyo PC25580 Remote Control (Pc-27s80)\">PC25580</a></div>\n"
+ "<div class=\"col-md-4\"><a href=\"/model/SFSPC25S80/_/_/Sanyo/PC25S80/\" title=\"Sanyo PC25S80 Remote Control (Pc-27s80)\">PC25S80</a></div>\n"
+ "<div class=\"col-md-4\"><a href=\"/model/SFSPC27S80/_/_/Sanyo/PC27S80/\" title=\"Sanyo PC27S80 Remote Control (Pc-27s80)\">PC27S80</a></div>\n"
+ "</div></div></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}