# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a[^>]*>([^<]+)<\/a>+"
test_str = ("<div class=\"row mb-xlg\"><div class=\"col-md-12\">\n"
"<div class=\"heading heading-border heading-middle-border\"><h3>Compatible Models</h3></div>\n"
"<div class=\"row show-grid\">\n"
"<div class=\"col-md-4\"><a href=\"/model/SFSPC19S80/_/_/Sanyo/PC19S80/\" title=\"Sanyo PC19S80 Remote Control (Pc-27s80)\">PC19S80</a></div>\n"
"<div class=\"col-md-4\"><a href=\"/model/SFSPC25580/_/_/Sanyo/PC25580/\" title=\"Sanyo PC25580 Remote Control (Pc-27s80)\">PC25580</a></div>\n"
"<div class=\"col-md-4\"><a href=\"/model/SFSPC25S80/_/_/Sanyo/PC25S80/\" title=\"Sanyo PC25S80 Remote Control (Pc-27s80)\">PC25S80</a></div>\n"
"<div class=\"col-md-4\"><a href=\"/model/SFSPC27S80/_/_/Sanyo/PC27S80/\" title=\"Sanyo PC27S80 Remote Control (Pc-27s80)\">PC27S80</a></div>\n"
"</div></div></div>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.