$re = '/Or(?!der)/m';
$str = 'findByNameOrAge
findByNameOrderByAge';
$subst = " or ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;