re = /Or(?!der)/m
str = 'findByNameOrAge
findByNameOrderByAge'
subst = ' or '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result