import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"user\\\":\\s+\\{\\s+\\\"id\\\":\\s+(?<user_id>[^,]+)";
final String string = "\"aepassword\": \"kmdAkcu)n>Ec_.a(m5P7?8-n\", \"aeci\": { \"outgoing_server\": \"mailrv.aaa.com\", \"email_footer\": \"C:\\\\ProgramData\\\\bbb\\\\AutomationNote\\\\Email\\\\aa_Mail_Footer.png\", \"email_header\": \"C:\\\\ProgramData\\\\bbb\\\\AutomationNote\\\\Email\\\\aa_Mail_Header.png\", \"signature\": \"C:\\\\ProgramData\\\\bbb\\\\Automation\\\\Email\\\\bb_Email_Signature.txt\", \"requires_authentication\": \"false\", \"reply-to\": \"us@aaa.com\", \"primaryaddress\": \"ussdev@aaa.com\", \"host\": \"ussdev@bbb.com\", \"entity_alternate_names\": \"usdev@aaa.com\", \"outgoing_port\": \"2675\", \"entityid\": \"wmid-1607548215055521\", \"name\": \"bbb_MailBox\", \"entitytype\": \"Sub-System\", \"entitytype\": \"Workplace\", \"technology\": \"O736i85\", \"tenantid\": 1000011, \"cloudprovider\": \"\", \"satellite\": \"sat-16107579705752592\", \"resourceid\": null, \"UDetails\": { \"creds\": { \"email\": \"NA\" }, \"id\": 14, \"name\": \"N/A\" }, \"encryptionKey\": \"5inqhg7ckj7klk2w4osk0\", \"user\": { \"id\": 5, \"name\": \"CRI Admin\", \"employeecode\": \"125\", \"email\": \"admin@aaa.com\" },";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}