# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"user\":\s+\{\s+\"id\":\s+(?<user_id>[^,]+)"
test_str = "\"aepassword\": \"kmdAkcu)n>Ec_.a(m5P7?8-n\", \"aeci\": { \"outgoing_server\": \"mailrv.aaa.com\", \"email_footer\": \"C:\\\\ProgramData\\\\bbb\\\\AutomationNote\\\\Email\\\\aa_Mail_Footer.png\", \"email_header\": \"C:\\\\ProgramData\\\\bbb\\\\AutomationNote\\\\Email\\\\aa_Mail_Header.png\", \"signature\": \"C:\\\\ProgramData\\\\bbb\\\\Automation\\\\Email\\\\bb_Email_Signature.txt\", \"requires_authentication\": \"false\", \"reply-to\": \"us@aaa.com\", \"primaryaddress\": \"ussdev@aaa.com\", \"host\": \"ussdev@bbb.com\", \"entity_alternate_names\": \"usdev@aaa.com\", \"outgoing_port\": \"2675\", \"entityid\": \"wmid-1607548215055521\", \"name\": \"bbb_MailBox\", \"entitytype\": \"Sub-System\", \"entitytype\": \"Workplace\", \"technology\": \"O736i85\", \"tenantid\": 1000011, \"cloudprovider\": \"\", \"satellite\": \"sat-16107579705752592\", \"resourceid\": null, \"UDetails\": { \"creds\": { \"email\": \"NA\" }, \"id\": 14, \"name\": \"N/A\" }, \"encryptionKey\": \"5inqhg7ckj7klk2w4osk0\", \"user\": { \"id\": 5, \"name\": \"CRI Admin\", \"employeecode\": \"125\", \"email\": \"admin@aaa.com\" },"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.