package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\W*?ENTRY\W*(?P<entries>[ ]*? \d+ (?:[.,] \d+)? [ ]*? - [ ]*? \d+ (?:[.,] \d+)? [ ]*? | [ ]*? \d+ (?:[.,] \d+)? [ ]*?)`)
var str = `ENTRY: 0.0975 - 0.101
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}