re = /^\W*?ENTRY\W*(?P<entries>[ ]*? \d+ (?:[.,] \d+)? [ ]*? - [ ]*? \d+ (?:[.,] \d+)? [ ]*? | [ ]*? \d+ (?:[.,] \d+)? [ ]*?)/mx
str = 'ENTRY: 0.0975 - 0.101
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end