import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\W*?ENTRY\\W*(?P<entries>(?>[ ]*? \\d+ (?:[.,] \\d+)? [ ]*?) - (?>[ ]*? \\d+ (?:[.,] \\d+)? [ ]*?) | (?>[ ]*? \\d+ (?:[.,] \\d+)? [ ]*?))";
final String string = "ENTRY: 0.0975 - 0.101\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}