using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\|)(?:(?!$)\s)+((?!\s*\w+:\/\/)(?:(?!$)[^|])+?)(?:(?!$)\s)*\|";
string input = @"https://stackoverflow.com | https://google.com | This is quite an interesting sentence, isn't it? |
https://randomsite.com | https://randomurl2.com | text | https://randomsite.com |
https://randomsite.com | https://randomsite.com |
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}