import Foundation
let pattern = #"(?:^|\|)(?:(?!$)\s)+((?!\s*\w+:\/\/)(?:(?!$)[^|])+?)(?:(?!$)\s)*\|"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://stackoverflow.com | https://google.com | This is quite an interesting sentence, isn't it? |
https://randomsite.com | https://randomurl2.com | text | https://randomsite.com |
https://randomsite.com | https://randomsite.com |
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)