import re
regex = re.compile(r"^(?<!(<!--.))(http(s?):)?([\/|\.|\w|\s|-])*\.(?:jpg|gif|png)$", flags=re.MULTILINE)
test_str = ("<img src=\"/images/lol/hallo.png\" />\n"
"/images/lol/hallo.png\n"
"/images/lol/hallo.png\n"
"<!-- /images/lol/hallo.png -->\n"
"<!-- <img src=\"/images/lol/hallo.png\" /> -->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")