re = /^(?<!(<!--.))(http(s?):)?([\/|\.|\w|\s|-])*\.(?:jpg|gif|png)$/m
str = '<img src="/images/lol/hallo.png" />
/images/lol/hallo.png
/images/lol/hallo.png
<!-- /images/lol/hallo.png -->
<!-- <img src="/images/lol/hallo.png" /> -->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end