const regex = new RegExp('(?P<before>(?:\\w+\\W+){5})
\\$\\d+(?:\\.\\d+)?
(?P<after>(?:\\W+\\w+){5})', 'gm')
const str = `I have a sentence with \$10.00 within it and this sentence is done. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}