re = /(?P<before>(?:\w+\W+){5})
\$\d+(?:\.\d+)?
(?P<after>(?:\W+\w+){5})/mx
str = 'I have a sentence with $10.00 within it and this sentence is done. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end