re = /^(?:19|20)?\d{2}(?!000|500|36[7-9]|3[7-9]\d|86[7-9]|8[7-9]\d)[0-35-8]\d\d\d{4}[vVxX]$/m
str = 'Format should be
937962723V
or
937962723X
or any 11 digit number according to the current format.
19345678901x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end