using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[a-z0-9\.\-\+]*):\/\/(?:[^\s:@\/]+(?::[^\s:@\/]*)?@)?(?:(?:25[0-5]|2[0-4]\d|[0-1]?\d?\d)(?:\.(?:25[0-5]|2[0-4]\d|[0-1]?\d?\d)){3}|\[[0-9a-f:\.]+\]|([a-z_-_0-9](?:[a-z_-_0-9-]{0,61}[a-z_-_0-9])?(?:\.(?!-)[a-z_-_0-9-]{1,63}(?<!-))*\.(?!-)(?:[a-z_-_-]{2,63}|xn--[a-z0-9]{1,59})(?<!-)\.?|[a-z_-_0-9](?:[a-z_-_0-9-]{0,61}[a-z_-_0-9])?(?:\.(?!-)[a-z_-_0-9-]{1,63}(?<!-))*|localhost))(?::\d{2,5})?(?:[\/?#][^\s]*)?\Z)";
string input = @"http://www.google.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}