use strict;
my $str = 'http://www.google.com';
my $regex = qr/((?:[a-z0-9\.\-\+]*):\/\/(?:[^\s:@\/]+(?::[^\s:@\/]*)?@)?(?:(?:25[0-5]|2[0-4]\d|[0-1]?\d?\d)(?:\.(?:25[0-5]|2[0-4]\d|[0-1]?\d?\d)){3}|\[[0-9a-f:\.]+\]|([a-z_-_0-9](?:[a-z_-_0-9-]{0,61}[a-z_-_0-9])?(?:\.(?!-)[a-z_-_0-9-]{1,63}(?<!-))*\.(?!-)(?:[a-z_-_-]{2,63}|xn--[a-z0-9]{1,59})(?<!-)\.?|[a-z_-_0-9](?:[a-z_-_0-9-]{0,61}[a-z_-_0-9])?(?:\.(?!-)[a-z_-_0-9-]{1,63}(?<!-))*|localhost))(?::\d{2,5})?(?:[\/?#][^\s]*)?\Z)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}