use strict;
my $str = 'ábécédééefg';
my $regex = qr/[^\w~!@#$%^&*()=_+`[\]{}\\|:;'"<>,.\/-]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";