package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^msl(?:s|[^a-rt-z]*)$`)
var str = `msl
msls
msl12324
msled
mslaaa
mslitiyy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}