$re = '/^msl(?:s|[^a-rt-z]*)$/m';
$str = 'msl
msls
msl12324
msled
mslaaa
mslitiyy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);