import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)\\d+(?:,\\d+)? ?x ?\\d+(?:,\\d+)?(?: ?x ?\\d+(?:,\\d+)?)*";
final String string = "Square 10 x 3 x 5 mm\n"
+ "Round 23/22; 24,9 x 12,2 x 12,3\n"
+ "Square 10x2\n"
+ "Straight 10x2mm\n"
+ "Round 23/22; 24,9x12,2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}