re = /(?<!\S)\d+(?:,\d+)? ?x ?\d+(?:,\d+)?(?: ?x ?\d+(?:,\d+)?)*/
str = 'Square 10 x 3 x 5 mm
Round 23/22; 24,9 x 12,2 x 12,3
Square 10x2
Straight 10x2mm
Round 23/22; 24,9x12,2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end