use strict;
my $str = 'div-item-2,4,maintype:social| heading:sdfsdf| social: 1, 2, 3 | table:Social| item:3| align:vertical| style:icon| isactive:1,8,0
div-item-0,4,maintype:menu| heading:Quick, Link| table:Menu | menuid:1| align:vertical| style:icon| isactive:1,0,0
div-item-1,4,maintype:text| heading: Name | title: Learn from here| logo:/photos/20/01.jpg| description: This is some description, so you can stay with us| isactive:1,4,0';
my $regex = qr/((\||(?<!^)\G)[^,|]*),(?=.*\|)/mp;
my $subst = '$1;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";