$re = '/^(?!.*(?: -|- ))[a-zA-Z\' ]+(?:[- ][a-zA-Z\']+)*$/m';
$str = 'abc-abc
asd asd asd asd
abc -abc
abc- abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);