re = /^(?!.*(?: -|- ))[a-zA-Z' ]+(?:[- ][a-zA-Z']+)*$/m
str = 'abc-abc
asd asd asd asd
abc -abc
abc- abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end