#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*\?).+$"
Local $sString = "text?textoajsf" & @CRLF & _
"taslkd?textoajsf" & @CRLF & _
"?lkjflkdf" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)