$re = '/(.*\?).+$/m';
$str = 'text?textoajsf
taslkd?textoajsf
?lkjflkdf
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;