$re = '/\b[A-Z](?![A-Z]*\b)\w*/m';
$str = 'Hi, How are You?
TEST
TESTing
aTEST
TeST
A
AAaA
AAa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);