re = /\b[A-Z](?![A-Z]*\b)\w*/m
str = 'Hi, How are You?
TEST
TESTing
aTEST
TeST
A
AAaA
AAa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end