using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Activity\s+(?<timed_out>[^\\n]+)";
string input = @"""Description"":""Job-2069950 Error in [InfrastructureServices/Dispatcher/Interface/MQ_InterfaceDispatcher.process/JMS Queue Requestor]\nActivity timed out\n\tat com.tibco.pe.core. ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}