$re = '/Activity\s+(?<timed_out>[^\\\\n]+)/m';
$str = '"Description":"Job-2069950 Error in [InfrastructureServices/Dispatcher/Interface/MQ_InterfaceDispatcher.process/JMS Queue Requestor]\\nActivity timed out\\n\\tat com.tibco.pe.core. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);