use strict;
my $str = '10:00:00:01';
my $regex = qr/((?'col'\D)(?'dig'\d\d))$/mp;
my $subst = ';$dig';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";