package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.+,\s)?(.*)$`)
var str = `Street number 1, Barcelona
Barcelona`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}