$re = '/^(?:.+,\s)?(.*)$/m';
$str = 'Street number 1, Barcelona
Barcelona';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);