import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\D*\\d){10,14}\\D*)?$";
final String string = "ab12c3456d7890efg\n"
+ "ab12c3456d789efg\n\n"
+ "ab12c3456d789012345efg\n\n"
+ "abc12\n"
+ "ab12c3456d789efg\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}