$re = '/^(?:(?:\D*\d){10,14}\D*)?$/m';
$str = 'ab12c3456d7890efg
ab12c3456d789efg
ab12c3456d789012345efg
abc12
ab12c3456d789efg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);