using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:http|ftp)s?://\S*\w|\w+|[^\w\s]+";
string input = @"My website: http://www.cartoon.com is not accessible.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}