package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:http|ftp)s?://\S*\w|\w+|[^\w\s]+`)
var str = `My website: http://www.cartoon.com is not accessible.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}