package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[^.]+\.[^.]+\.[a-zA-Z]{2,}|[^.]+\.[a-zA-Z]{2,})$`)
var str = `test.upsidestudio.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}