re = /^(?:[^.]+\.[^.]+\.[a-zA-Z]{2,}|[^.]+\.[a-zA-Z]{2,})$/
str = 'test.upsidestudio.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end