import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=href=[\"'])(?<url>[^\"']*)(?=[\"'][^\\>]*\\>((?<content>.*?)\\<\\/a>))";
final String string = "<a href=\"prova\">prova</a><a href=\"prova2\">prova2</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}