$re = '/(?<=href=["\'])(?<url>[^"\']*)(?=["\'][^\>]*\>((?<content>.*?)\<\/a>))/';
$str = '<a href="prova">prova</a><a href="prova2">prova2</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);