const regex = new RegExp('\\b(example)(?:\\s+\\1)+\\b', 'g')
const str = `my example example string contains example some text`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);