re = /\b(example)(?:\s+\1)+\b/
str = 'my example example string contains example some text'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result