package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]+|".*?"`)
var str = `we found "the little cat" is in the hat, we like "the little cat"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}